OVH Plesk update failed: aum & modsecurity-crs have unmet dependencies

En los últimos días estamos teniendo bastantes problemas con servidores PLESK que tienen instalado MODSECURITY sobre Debian 8 y las actualizaciones de Plesk.

Al intentar actualizarse Plesk da el siguiente error:

The apg-get failed with the following message:
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
aum : Depends: libapache2-mod-security2 but it is not going to be installed
modsecurity-crs : Depends: libapache2-mod-security2 (>= 2.8.0) but it is not going to be installed

Y no se actualiza PLESK.

La solución es entrar por SSH al servidor y ejecutar los siguiente dos comandos:

dpkg --remove modsecurity-crs
dpkg --remove aum

Y ya podemos volver a actualizar PLESK normalmente.

Espero que os sirva.

2 comentarios en “OVH Plesk update failed: aum & modsecurity-crs have unmet dependencies

    1. Hablando de Internet y de SEO

      Hola Eduardo. Me alegra mucho que te haya ayudado y sobre todo ahorrado tiempo. Eso es de lo que se trata y por eso compartimos estas cosas. Muchas veces la solución es sencilla pero para llegar a ella hemos pasado más de 2 días de investigación y pruebas (como en este caso). Saludos!

      Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.